Dizüstü bilgisayar DHCP adresi alabilir, ancak aynı cihazlara takıldığında başka cihazlar kullanılamaz.

Şu anda, 1, 10, 20 ve 30 numaralı portlar ile aralarında 46-47 numaralı bağlantı noktalarına yerleştirilmiş 1 adet Juniper ex3300 ve 1x HP ProCurve 2848 ağım var. Ex3300, tüm vlans ve bunlar ve internet arasındaki güzergahlar için DHCP sunucusu görevi görür.

Kablosuz AP'ler (havalimanı ekspres/aşırı) çoğu durumda bu anahtarların her birine doğrudan bağlanır, ancak bazılarında Mikrotik RB260gs'ler, aynı vlanslarla gövde bağlantıları üzerinden bağlanır.

Doğrudan bağlı AP'ler iyi çalışır ve anahtarlar herhangi bir VLAN'a yerleştirilebilir ve bağlantıyı koruyabilir. RB260gs, dizüstü bilgisayarım takıldığında doğru şekilde çalışıyor (VLAN ile ilgili DHCP adreslerini, tam bağlantıyı sunuyor). Başka bir aygıtı aynı bağlantı noktasına bağladığımda, aygıt bir DHCP adresi almıyor ve bağlantı yok.

Bunu şimdiye kadar bir DHCP adresi almayan Onkyo AV Alıcısı, Havaalanı Extreme, Airport Express ile test ettim. İki pencereli makine DHCP'yi alır (bunlardan sadece biri üzerinde temiz bir pencere vardır).

Burada hiçbir şeyim yok. Herkes yardım eder mi?

[UPDATE] - Configs Mikrotik VLAN Config

HP CONFIG

hostname "MUST-CSW2-HP2848"
mirror-port 39
interface 6
   name "Captains_Cabin_Express"
exit
interface 11
   name "VIP_AP"
exit
interface 20
   name "ASW1-Master"
exit
ip default-gateway 172.20.11.254
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   ip address dhcp-bootp
   tagged 10
   no untagged 1-9,11-48
   exit
vlan 10
   name "Ship"
   untagged 1-19,21-38,40-44
   ip address 172.20.11.253 255.255.254.0
   tagged 20,45-48
   exit
vlan 20
   name "Crestron"
   ip address 172.20.20.253 255.255.255.0
   tagged 20,45-48
   exit
vlan 30
   name "Guest"
   untagged 39
   ip address 172.20.30.253 255.255.255.0
   tagged 20,45-48
   exit
vlan 99
   name "Management"
   exit
interface 20
   monitor
   exit
spanning-tree

JUNIPER CONFIG

****************output omitted**********************

        dhcp {
            traceoptions {
                file dhcp_logfile;
                level all;
                flag all;
            }
            pool 172.20.10.0/23 {
                address-range low 172.20.10.50 high 172.20.11.149;
                name-server {
                    8.8.8.8;
                    8.8.4.4;
                }
                router {
                    172.20.11.254;
                }
            }
            pool 172.20.30.0/24 {
                address-range low 172.20.30.25 high 172.20.30.225;
                name-server {
                    8.8.8.8;
                    8.8.4.4;
                }
                router {
                    172.20.30.254;
                }
            }
            pool 172.20.20.0/24 {
                address-range low 172.20.20.50 high 172.20.20.225;
                name-server {
                    8.8.8.8;
                    8.8.4.4;
                }
                router {
                    172.20.20.254;
                }
            }
        }
    }

****************output omitted*************************

    ge-0/0/44 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
            }
        }
    }
    ge-0/0/45 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ Ship Guest Crestron-Control ];
            }
        }
    }
    ge-0/0/46 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ Ship Guest Crestron-Control ];
            }
        }
    }
    ge-0/0/47 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ Ship Guest Crestron-Control ];
                }
            }
        }

**************output omitted******************

    vlan {
        unit 0 {
            family inet;
        }
        unit 1 {
            family inet;
        }
        unit 10 {
            family inet {
                address 172.20.11.254/23;
            }
        }
        unit 20 {
            family inet {
                address 172.20.20.254/24;
            }
        }
        unit 30 {
            family inet {
                address 172.20.30.254/24;
            }
        }
        unit 100 {
            family inet {
                address 172.20.100.14/28;
            }
        }
    }
}

***************output omitted******************

routing-options {
    static {
        route 0.0.0.0/0 next-hop 172.20.100.1;
    }
}
protocols {
    igmp-snooping {
        vlan all;
    }
    rstp {
        bridge-priority 0;
    }
    lldp {
        interface all;
    }
    lldp-med {
        interface all;
    }
}
ethernet-switching-options {
    storm-control {
        interface all;
    }
}
vlans {
    Crestron-Control {
        description "Crestron Network Resources";
        vlan-id 20;
        interface {
            ge-0/0/47.0;
            ge-0/0/44.0;
            ge-0/0/45.0;
            ge-0/0/46.0;
        }
        l3-interface vlan.20;
    }
    Guest {
        description "Guest Network Resources and User Devices";
        vlan-id 30;
        interface {
            ge-0/0/47.0;
            ge-0/0/46.0;
            ge-0/0/45.0;
            ge-0/0/44.0;
            ge-0/0/10.0;
        }
        l3-interface vlan.30;
    }
    Internet_Connection {
        description "Connection to Peplink30 via Bridge_MAIN";
        vlan-id 100;
        interface {
            ge-0/0/0.0;
        }
        l3-interface vlan.100;
    }
    Management {
        vlan-id 99;
        l3-interface vlan.0;
    }
    Ship {
        description "Hardware and Crew";
        vlan-id 10;
        interface {
            ge-0/0/47.0;
            ge-0/0/11.0;
            ge-0/0/12.0;
            ge-0/0/13.0;
            ge-0/0/14.0;
            ge-0/0/15.0;
            ge-0/0/16.0;
            ge-0/0/17.0;
            ge-0/0/18.0;
            ge-0/0/19.0;
            ge-0/0/29.0;
            ge-0/0/44.0;
            ge-0/0/45.0;
            ge-0/0/46.0;
        }
        l3-interface vlan.10;
    }
    default {
        vlan-id 1;
        interface {
            ge-0/0/47.0;
        }
        l3-interface vlan.1;
    }
}
poe {
    interface all;
}
0
Juniper 'inizin konfigürasyonunu göstermeye yardımcı olabilir.
katma yazar SitWalkStand, kaynak
Herhangi bir cevap size yardımcı oldu mu? Eğer öyleyse, cevabı kabul etmelisiniz, böylece soru sonsuza kadar haşhaş olmayacak, bir cevap aramayacaktır. Alternatif olarak, kendi cevabınızı sağlayabilir ve kabul edebilirsiniz.
katma yazar Ron Maupin, kaynak
Herhangi bir VLAN'da bir erişim noktasını doğrudan (veya HP üzerinden) bağlayabildiğim ve doğru DHCP teklifini alabildiğim için ardıç düzenini düşünmeme rağmen. Mikrotik (config ayrıca gönderilmiştir) veya Mikrotik-HP bağlantısı bir yapılandırma sorunu oldukça eminim.
katma yazar MikeJ-UK, kaynak
Ayrıca, tüm yapılandırmayı istediğinizde lütfen bana bildirin. Ben yönetim kurullarında yeniyim ve spam olarak kabul edilenleri bilmiyorum.
katma yazar MikeJ-UK, kaynak

1 cevap

Ağlar HP'nizden yönlendirilirse (DHCP Sunucusu ile aynı VLAN'da bir Layer2 bağlantınız yoksa), DHCP Yayınlarının kendi DHCP Sunucusuna erişmesine izin vermek için bir IP Yardımcısı eklemeniz gerekir.

Sizin için bir arayüz-config şu şekilde görünebilir:

vlan 30
   name "Guest"
   untagged 39
   ip address 172.20.30.253 255.255.255.0
   ip helper-address x.x.x.x (IP Address of DHCP Server)
   tagged 20,45-48
exit
2
katma